Incident

Saturday Mar 11, 2023

 Degraded performance

SSO SAML issues
Identified
Some customers are facing issues logging in via SSO. We are working on resolving this right away!
Mar 11, 2023 - 12:30PM
Investigating
Upon investigation, we learned that our vendor who helps us manage SSO login had an incident. Their updated versions of libraries caused some panic. Unfortunately, a handful of customers using SSO are affected. Some of their responders are not able to login but responders who are already logged in are not facing any issues.
Mar 12, 2023 - 02:22AM
Update
After long meetings with our vendor for SSO, we have reverted all package updates. Most systems are back in production
Mar 12, 2023 - 03:00AM
Resolved
Reverting the upgrades was enough for all systems to work again. All users can login using SSO 👏 We have reached out to affected customers separately over email. Thank you for your patience.
Mar 12, 2023 - 03:25AM

Components affected

Dashboard

Reported on

Sat, Mar 11, 2023 12:30 PM (UTC)

Resolved at

Sun, Mar 12, 2023 3:25 AM (UTC)